Comm32 Logo
Home Button  Buy Button 

Topic:   SComm32 not installing properly - Windows 10

By: David SteelePosted on: Sep 1 2016 at 01:06:11 AM
I am trying to install SComm32 on an Acer netbook which recently updated from Win7 to Win10 so I can use an existing Excel app to gather data from the sounder and GPS on my boat. The installer runs ok but when I open Excel and look at the list of ActiveX controls, SComm32.SComm is not present. However, a control called SCommlib.SComm is there instead. I noticed also that there is another control present, Serial Port ActiveX Control 3.0, which seems to have sneaked in somehow - could this be interfering with the installation? (I use another faster Win10 laptop for editing, etc on the Excel app and SComm32 works perfectly there)

By: David SteelePosted on: Sep 1 2016 at 10:12:28 AM
I think I may have sorted this out - on my 32 bit netbook, which ran a stripped down version of Win7 before the Win10 update, SComm32 seems to install a control described as SCommlib.Scomm, while on my 64 bit laptop, where I did a clean Win7 reinstall before upgrading to Win10, the control appears as SComm32.Scomm. I used CreateObject references to SComm32 in the code in the Excel spreadsheet and while these will have to be edited to reflect the different SComm description, I assume the commands will work properly once this has been done. Fingers crossed!

By: GuestPosted on: Sep 1 2016 at 09:38:52 PM
I beleive there was a version change that changed the name of the control.

In some earlier versions of the control it would not work correctly if created in code. You could drop it on a form and it worked fine but declaring in code wasn't quite the same as MSComm32. Worked ok in vb6 but not in vba or something like that.

The latest versions do have the same behaviour as MSComm32 when declared in code and at that time the name of the ocx was changed so that there would be no conflict with previous versions.

Or something like that.

I guess you had different versions installed on different machines?

Check the versions. Should be v9 and the ocx file itself is "scomm32x.ocx".

You mentioned serial port activex 3.0 no idea what that is. Maybe installed by some other application.

By: MikeLBergPosted on: Sep 1 2016 at 09:42:08 PM
Yes. And the name change made Scomm32 have the same naming convention and syntax as MSComm32 so any project that previouslsy used MSComm32 could be switched to use scomm32 with very little editing.

By: David SteelePosted on: Sep 4 2016 at 08:13:36 PM
Thanks for the insights. I did indeed turn out to have different versions in different machines and tried to decant an Excel app using the older version into the machine with the newer one. It should be straightforward to fix the problem by reinstalling the SComm32 controls using the new version.

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- SComm32 not installing properly - Windows 10

Enter the numbers.

Your name here is optional